[AMPL 24842] problem with optimization memory exhausted

Dear Robert,

I have had the following statement in my model running log:

"Optimization exhausted available memory

Waiting for other threads to finish… 83991s
Waiting for other threads to finish… 84121s
Waiting for other threads to finish… 84250s
Waiting for other threads to finish… 84379s

Waiting for other threads to finish… 84507s
Warning: Possible non-determinism after error

Explored 0 nodes (0 simplex iterations) in 84607.49 seconds (173791.74 work units)
Thread count was 1 (of 12 available processors)

Solution count 0

Solve interrupted (error code 10001)
Best objective -, best bound -, gap -
Gurobi 10.0.3: ran out of memory
ampl: "

I interrupted AMPL after a day period (24h=84600s) of running.
I would like to ask you if I continued to run the model after 24 hours, could AMPL have given a solution to the model, given the elements that are in the log. And what do you think I must do have AMPL give solution to that problem.

Many thanks for your help.

Best regards.

The main part of Gurobi’s algorithm builds a search tree. Even in a successful run, the search tree can grow quite large during the solver run. Error code 10001 indicates that the search tree became too large to fit in your computer’s RAM memory. To avoid this error, you can use Gurobi’s nodefilestart setting to limit the amount of memory used for search nodes; when the number of gigabytes of memory exceeds the the nodefilestart value, nodes are compressed and written to disk. Gurobi recommends trying 0.5, which can be specified by adding nodefilestart=0.5 to your gurobi_options string – or if you are not yet specifying a gurobi_options string, by giving the command

option gurobi_options ‘nodefilestart=0.5’;

before solving. You can experiment with larger nodefilestart values if your computer has a large amount of memory, but keep in mind that Gurobi will also need a substantial amount of memory for other purposes besides building the search tree.

Also you can add a timelim setting to your gurobi_options string, to stop the solver run normally rather than interrupting it. For example, timelim=86400 will stop the run after 1 day. Information on all Gurobi settings can be found on our Gurobi Options page.

Finally, if you need to ask for more help, ask Gurobi for a detailed log by adding outlev=1 to your gurobi_options string. Then include all of the resulting log listing with your question; since the log may be very long, you may want to copy it to a file, then attach the file.

Dear Robert,

Many thanks for your assistance.
I had put the gurobi_options string outlev=1. Please find attached the entire log to see if there is additional information which can permit you to help more.
Also I would like to ask you for the larger nodefilestart values up to what values can I take.

(Attachment Log_Vivi1.txt is missing)
5_99fe_YNDNS.dat (135.6 KB)

This has been answered at discuss.ampl.com: