AMPL/Mosek Interface


I am getting this issue currently:

*** Error. The MOSEK/AMPL interface is not available on this platform.

Error executing “solve” command:

Need help in this regard,



This is not a standard AMPL solver error message. Can you provide some details that will help determine the cause?

  • What platform (operating system and processor) are you using?

  • Did you get MOSEK from the AMPL Portal?

  • When did you download the MOSEK/AMPL solver software?

  • What output do you see from this AMPL command?
    shell "mosek -v";


Surely, I can provide you with all required criteria you asked for:

  • I am using Windows 10 Pro and the machine is Intel i5 @ 2.40GHz, 1.38 GHz.

  • Yep, I tried with Mosek from Portal and I have my own license as well.

  • I downloaded recently like 3-4 days ago.

  • output:
    ampl: shell “mosek -v”;
    MOSEK version 10.0.46
    Return code - 0 [MSK_RES_OK]

Best regards,

The version details from “mosek -v” do not have the form that we would expect. Try downloading our latest build of MOSEK/AMPL using these steps:

  • Go to

  • Under option “2. Download individual MOSEK solver module”, click on “Download MOSEK module for Windows” to download a zipfile

  • Double-click on the zipfile to uncompress it, and copy the following files into your AMPL folder: mosek.exe, mosek64_10_0.dll, svml_dispmd.dll, and tbb12.dll.

Then start AMPL again, and do another version check; you should see the following:

ampl: shell "mosek -v";
AMPL/MOSEK Optimizer [10.0.43] (Windows AMD64), driver(20240118), MP(20240115)

If you see this, then MOSEK should run correctly. However, if you see some other message or if MOSEK still doesn’t run, then report the “mosek -v” message that you see, and also the error message that you get when you try to run MOSEK. (One or both of these messages might be different from the ones you saw before.)

Hi, I tried all method, yet I am getting:

By running Mosek:

*** Error. The MOSEK/AMPL interface is not available on this platform.

And by running:

ampl: shell "mosek -v";
MOSEK version 10.0.46
Return code - 0  [MSK_RES_OK]

These messages show that you are still not executing the version of MOSEK that works with AMPL. You might have two mosek.exe files on your computer now, and AMPL is not finding the right one. Here are two steps you can take to check:

  • Use the Windows file search feature to look for files named mosek.exe. If there is more than one file with this name, delete or rename the one that you did not download according to our instructions.

  • Look in the folder that containsampl.exe and ampl.lic. Be sure that it contains the mosek.exe that you downloaded from us, and also the files mosek64_10_0.dll, svml_dispmd.dll, and tbb12.dll.

If you cannot fix the problem with these steps, then let us know what you saw; and also, please take a screenshot of the folder that contains ampl.exe, and paste it into your reply. (If there are too many files to fit in the Windows folder display, then you can use more than one screenshot.)

Hi Robert,

Thanks for your help, it really does work, AMPL was reading my default Mosek optimizer.

Issue is resolved.

Best wishes,