Time limit in NEOS server when using Kestrel

Dear friends,

Some of my students are trying to solve some optimization problems. Since the problems involve many variables and constraints, they are trying to solve it in the NEOS server. Some of them have the data in excel files, and since the NEOS server web interface does not admit excel files, they compile the model in their laptops and then send the model to NEOS via Kestrel.

The problem is that when sending the problems to NEOS via kestrel, only 5 minutes of CPU time is allocated to the problems. It seems that the problems sent to NEOS via kestrel are assigned a short priority (Short Priority: submit to higher priority queue with maximum CPU time of 5 minutes). I remember that this was not the case last year. Maybe something has been changed in the NEOS server.

So my question is: is it possible to send a problem to NEOS server via kestrel so that the problem is allowed to run for up to 8 hours?

Thanks in advance for your help!

Dear Jose,

We had not previously heard of this change. We’ll have to talk to NEOS Support to determine whether they are deliberately limiting Kestrel submissions to the higher priority queue, and if so, whether there is some way to get around the 5-minute limitation. We’ll let you know what we find out.

You may also want to check https://ampl.com/start-free-now/ to see whether any of the options there would be helpful for your students.

Thanks for your quick reply, Dr. Fourer.

I have just seen at

the following:

Jobs submitted with the priority of long can run for at most 8 hours. Jobs submitted with the priority short can run for at most 5 minutes. Results for long jobs do not stream. You can control the priority as follows:
ampl: option kestrel_options “solver=xxx priority=short”;
ampl: option kestrel_options “solver=xxx priority=long”;

In this driver we set the default priority to short so that we can retrieve output from the solver.

So it seems that now, by default, jobs submitted to NEOW via kestrel are assigned a short priority and they are allowed to run only for 5 minutes. I insist that this was not the case a year ago. Fortunately, using
option kestrel_options "solver=xxx priority=long
this can be changed.
Thanks for your help.

Hi @Jose,

The kestrel driver is now defaulting to priority=short so that you can see output from the solver in short runs. You can add priority=long to kestrel_options (NEOS: Kestrel client — AMPL Resources) to increase the time limit.

Thanks a lot for your confirmation!