I’ve been trying to solve a model with baron (on linux) but I consistently get the following error:

: Unable to find/load AMPL library cannot open shared object file: No such file or directory

I also tried solving one of the examples that come by default with ampl (diet.mod, diet2.dat), and I get the same error.

The library is ineed not contained in the bundle I downloaded a few months ago. I tried to create a new bundle that only contains ampl and baron, but the issue persists (and the library is missing from such a minimal bundle as well).

It seems to me that the library is missing by mistake. Is that the case?


Hi @stefano.coniglio,

Thank you for reporting this issue. We have just reverted the last release of the baron driver for Linux as a quick workaround while we fix the latest build.

Hi @stefano.coniglio,

The latest version of BARON is now being distributed again for Linux. There were some issues with the build other than the missing library that were now fixed. You can download it by generating a new bundle.

Thanks a lot. It all works just fine now.